C Programming Course – Worksheet One

Introduction

This is the first worksheet in the C programming course.  By the end of this worksheet you should be able to:

1) Edit, compile and run C programs using the Visual C++ interface.

2) Understand a simple program which prints to the screen. 

3) Do basic arithmetic using C – plus, minus, multiply and divide.

4) Use simple loops to perform iterations with while and for.
5) Understand the use of if and else in C programming.

6) Write programs which perform simple algorithms.

We will be teaching this course using the Visual C++ system.

[Note for experts:  If you are an experienced computer user you may prefer a different compiler.  That is completely fine as long as work which is handed in is completely compatible with ANSI standard C.]

Notes on these notes

In these notes this font indicates something that appears on a computer screen or which should be typed in to the computer this font indicates where you should substitute something.  For example:

edit filename
means type edit followed by the name of a file.  Comments in square brackets are asides or explanatory notes often these are intended for experts who might want to know more about the subject.

Starting the C compiler and building a program

You will have to follow these steps every time you compile a new program.

1) Start the compiler program (we will be using Microsoft Visual C++) from  Start menu (bottom left) select Start->Programs->Programming->Microsoft Visual Studio->Visual C++.  (This might take a long time the first time you do it).

2) Now select File->New->Projects->Win32 Console Application.

3) In the box marked project name type HelloWorld (or whatever you want to call this program).  Choose a different name every time you start a new program.

4) In the box marked location choose where you want to save this project (you can leave this as it is if you want).

5) Choose “a simple Application” and press OK (twice).

6) Double click on “Hello World Classes” then Globals, then Main in the window that opens up.

[Note: In this course we will only be building console type applications (non-graphical, text-based applications.  Feel free to experiment with other types of applications if you want.]

To keep things tidy you may want to put all your C programs in a separate folder.  For this course I suggest that you create a separate folder on your H drive to keep things tidy.  (Choose that as where to start projects in step 4 above).

You should now see a screen which contains:

// HelloWorld.cpp : Defines the entry point for the console 

// application.

#include "stdafx.h"

int main(int argc, char* argv[])

{


return 0;

}
This is the starting point for our first program which is going to be very simple indeed.

The first program – "Hello World" – the program itself

Since this is your first program it will be good practice to type it in.  Here it is:

// HelloWorld.cpp : Defines the entry point for the console 

// application.

/* Hello World – my first program to say hello */

#include "stdafx.h"

#include <stdio.h>

int main(int argc, char* argv[])

{


printf ("Hello World\n");


return 0;

}

Be careful to type this in exactly as it is here.  (The number of spaces isn't important

but just about everything else is important – particularly semi-colons).  For the moment, don't worry about how it works and concentrate on accurate typing.  

The first program – "Hello World" – compiling and running it

Now you've written your first program it's time to see if it works.  The first step is to compile the program.  From the build menu select “Build HelloWorld.exe”.  If you have typed everything correctly this should work with no errors.

The next stage is to run the program.  This is done by selecting Build->Execute.  Once you have done this you should see a window containing the message:

Hello World

Press any key to continue
Congratulations, you have just compiled and run your first C program.  OK, it doesn't do anything very special but it's a start.  Do what the window says and press a key to exit your program.  Now let's have a look at how this simple program works.

The first program – "Hello World" – how it works

Let's go through the "Hello World" program line by line to see what each bit does.

The first lines are:

// HelloWorld.cpp : Defines the entry point for the console //application.

/* My first C program which prints Hello World */

as you probably guessed, this line doesn't actually DO anything.  It is called a comment and everything which within a comment is ignored by the compiler.  A comment starts with either with // or it starts with /* (pronounced "slash star") and continues until it finds */ (pronounced "star slash" logically enough).  If you forget to close your comment with the */ then you can accidentally comment out more than you intended – needless to say, this is a bad thing.  [As a beginning programmer your lecturer accidentally confused which way round the /* and */ went and very carefully over some hours, commented out an entire program.]  The program works just as well without the comment.  If the compiler ignores them then why have comments?  They are there to help you and other people who might look at your code (course markers for example) to understand what is going on.  We will talk about comments more later.  For now, it is enough to know that it is good style to put some comments in your code.  Don't go over board and comment on every little thing you do – but do put comments on anything which might be confusing and to say what each large block of code in your program does.

The next lines are:

#include "stdafx.h"

#include <stdio.h>

these tell the program to include header files called stdio.h and stdafx.h.  The first one (stdafx) is added by the Microsoft compiler.  It takes care of things like the “press any key to continue” and will be added to every program you write using Visual C++.  Don’t worry about it since it will be added automatically. The second header file <stdio.h> contains standard input and output routines for C programs.  In this case, we are including it so that we can use the printf command (see later).  There are a number of other useful header files which we will cover in detail later in the course.  For example, math.h contains some basic mathematical functions. 

The next line is:

int main(int argc, char* argv[])

which declares the main function of the C program [the int means that the main function returns an integer – this and the parts inside the bracket will be explained later].  

IMPORTANT RULE: Each C program must have one and only one main function declared.  In effect it says "start here" to the compiler.  This is what the comment about “entry point” means.

The next line is so short you might have missed it:

{
Or as C programmers pronounce it left curly bracket or even open curly bracket.  This tells the compiler that a block of code starts here and continues until } or right curly bracket.  Note that, as we shall see later, blocks of code can nest inside each other.  It is good style to indent your code to show up code blocks like this:

{


/* this is the outer code block */

      {

          /* this is the inner code block */


}

      /* this is the outer code block again */

}

{ and } are also sometimes known as braces and the way you indent your code is known as brace style.  This will be discussed in more detail later.  For now, just take my word for it that you really should indent code blocks in some way.

IMPORTANT RULE: Curly brackets define code blocks – a good programmer should indent code blocks to make the program clearer.  More will be said about how to do this later.

Finally we come to the very heart of our "Hello World" program (in fact the only line which is really doing any work whatsoever):

printf ("Hello World!\n");
As you probably guessed, printf means print to screen.  The string within the double quotes is what is printed.  The only confusing thing is that the printf statement takes the blackslash \ as special (in fact the C language itself takes them as special – they are called escape sequences.  In this case we used \n combination which means start a new line.  A few other things which can be done with the blackslash character include printing quote marks \", printing the backslash itself  \\, printing a tab \t.  A complete list is given in the course book K&R page 38.

IMPORTANT RULE: All statements in C require a semi-colon at the end.  Don't worry for now about exactly what a statement is but think of it as any line of code inside a code block.  If you miss a semi-colon then the compiler will complain bitterly about your code – and it will probably complain in an entirely unhelpful way.

Exercise 1: 

Change the "Hello World" program so that instead of printing

Hello World! it prints "Hello World!" (i.e. it puts double quotes round).

Exercise 2: 

Change it to print:

"Hello"

"World"

!

on three separate lines (you need only one print statement).  [Your printf statement should look pretty confusing at this point – you may already see good reasons why programmers use comments to remind them what the program does.]

The next line is:


return 0;

which does exactly what it says – it returns zero (in this case, it returns the value to the operating system – don't worry about what Windows does when it gets it – that's another story).  Like the comment line, this line is sometimes missed out – but it is convention for a C program to return 0 to indicate that it has finished successfully.  [Indeed, C programmers know that the real reason the Roman empire fell was that, because they had no number zero, they had no way to successfully return from C programs].

Finally we come to:

}

which indicates that this particular block of code (the main function remember) is now finished.

OK – you've probably heard enough about "Hello World!" so let's move on to your second C program.  Close down the project by selecting “Close Workspace” from the file menu.  Remember, when you have finished with a program always do Save All (if you want to keep it) and Close Workspace if you want to move on to another program.

A program to add two numbers together

Again we're going to look at a very simple program.  This time the program adds two numbers together:

#include <stdio.h>

/* Add two numbers together */

int main(int argc, char *argv[])

{

    int a,b,c;

    a= 3;

    b= 2;

    c= a+b;

    printf ("%d + %d = %d\n",a,b,c);

    return 0;

}

To save time you are going to copy this program rather than type it yourself.  First you must make a link to where the course files are kept.  To do this you must follow the following steps:

1) Open “My Computer” from the desktop by double clicking.

2) Under the “Tools” menu select “Map Network Drive”
3) Under Drive, select “F:” from the pull down menu (it doesn’t really matter which letter but I will assume in these notes you used F.
4) In the “Folder” box type \\w2ksan0\StaffFS\rgc2\Cprogramming
5) Click Finish
If you have done all this right you should get a directory which contains folders for the various weeks of this course.  In the directory for worksheet one you should see a number of files with names like beans.cpp, bfloats.cpp, addtwo.cpp.  (You may not be able to see the .cpp part depending on how you have set up your computer).  Copy these files onto your own directory space on your H drive.  (One way to do this it to select all the files by dragging, right mouse and click copy then move to the folder you want things to go in, right mouse and click paste).
Now we’re going to look at the first and simplest of these files: addtwo.cpp.  Here’s how to open, compile and run a .cpp (source file) using Microsoft C++.

1) Select File->Open.

2) Find the file you want (in this case, addtwo.cpp on your H drive) and click Open.

3) Select Build->Build and click YES to create a default workspace.

4) If this worked then select Build->Execute to run it.

You should see it printing:

3 + 2 = 5

which shouldn't surprise many people.

The first new thing in this program is the variables.  In this case we have three variables called a, b and c which are declared to be integer using the int statement at the top of the main program block.  In C, unlike some, more anarchic programming languages, we have to tell the compiler about every variable which will be used.  This is called declaring a variable's type.  int means integer (as you probably guessed) other variable types will be introduced soon enough.  With a few exceptions variable names in C can be any combination of letters, numbers and underlines.  [The exceptions are the C reserved keywords such as int.  For obvious reasons it would be confusing to have an integer called int].

IMPORTANT RULE: All variables used by the program must be declared.  Variable declarations should be the first things in any program block after the left curly bracket to start the block.

%d in a printf statement tells the printf statement to expect an int to show up in the argument list of the printf statement after the closing quote and to print the value of that integer in place of %d.  Note that we could equally well have written:

printf ("%d + %d = %d\n", a, b, a + b);

or even

printf ("%d + %d = %d\n",2 , 3, 2 + 3);

or if we were a little less hidebound

printf ("%d + %d = %d\n",2,2,5);

It's all the same to printf.

CAUTION:  Make sure you give the same number of “arguments” after the string as you requested.  These two examples below show problems which might occur.

printf ("%d + %d = %d\n", a, b, c, a+ b + c);

/* Hmm..  This might not do what I expect */

or even

printf ("%d + %d + %d = %d\n",a,b,c);

/* Who knows what this will do – whatever it is, it won't be good */

the last example is particularly bad.  The very best you can expect it to do is print gibberish.

Exercise 3:

i) Change the program to subtract one number from the other.

ii) Change it to multiply the two numbers.  (in C, as in most programming languages, * means multiply)

iii) Change it to divide the two numbers. (in C, again as in most programming languages, / means divide)

CAUTION: Combining numbers doesn't always work as you might expect.  What answer does the following line get?

printf ("Answer is %d\n", 2+2 * 4);

Many beginning programmers are confused when this gets the answer 10 not 16.  When C evaluates an expression, multiplication and division are evaluated before addition and subtraction.  If you are not sure which order an expression will be evaluated in, use brackets as in:

printf ("Answer is %d\n", (2+2) * 4);

Floating Point Numbers

You probably found that part iii of the exercise didn't get the answer correct – or at least didn't get what most people think you should get when you divide 3 by 2.  Some of you might have predicted that.  The answer is to use floating point numbers declared using float  in place of the ints you were using before.  floats are printed by a printf statement using %f instead of %d.

Exercise 4:

Change the division program to use floating point numbers.  Note that you can specify floating point numbers in scientific notation and with decimals for example:

float c;

c= 2.997924580e8;

CAUTION: combining floats and ints can be problematic.  As you did last time, close your current project and open bfloats.cpp. 

#include <stdio.h>

int main()

/* This program doesn't behave as you think it might */

{

    int a= 3;  

    int b= 2;

    float d;

    d= b*(a/b);

    printf ("d is %f – or is it\n",d);

    return 0;

}

This might not do what you expect.  Build and execute the program and see what happens.  We will learn how to deal with this properly later.  The problem is that the program divides two integers within the brackets before doing anything else. Note also that this fragment of code initialised the variables when it declared them.  That is to say, it set a to 3 at the same time as it was declared to be int.  One way round this is to do the calculation in stages:

d= a;

d= d/b;

d= d*b;

Make this change to the code and check that it does what you expect.

Another way round this, if you're using numbers not variables is to remember that if you give a number a decimal point then C thinks of it as a floating point number.  Close down your project and select 

File->Open and find thirds.cpp

float f;

f= 1/3;

printf ("f is %f\n",f);

f= 1.0/3.0;

printf ("f is %f\n",f);

In conclusion, you should be very careful when dividing ints and expecting an answer which is a float.
The While Loop

An important construct in C programming is the while loop.  while tells a program to keep doing something while a condition is true.

Open the program in beans.cpp.
#include <stdio.h>

int main()

/* How many beans make five */

{

    int a= 1;

    while (a <= 5) {

        printf ("%d bean(s)\n",a);

        a++;

    }

    printf ("make five\n");

    return 0;

}

Compile and run it as before.  In C, a++; is shorthand for a= a+1; another shorthand notation is a+= 1;  which also means add one to a (but of course other numbers could be added using that notation.  There are equivalent expressions for -=, *= and /=.

The while statement went round the loop until its condition was met.  The loop is defined by a code block as discussed earlier – and the code block is run until the expression within the while statement is false (in this case while a was less than or equal to five).

IMPORTANT RULE: The while statement didn't have a semi-colon after it.  This is because the while statement wasn't really finished until after the end of its code block.  The code block including printf and a++ stood in place of the semi-colon.  [If we had instead written while (a <= 5); the program would simply have kept checking whether a was less than or equal to five without doing anything else – forever.  That would be a bad thing and it would be time to Ctrl-C the program.]

More About While loops

(a <= 5) is the expression which the while loop checked in the above example.  There are a number of other ways we can construct expressions.  A true expression evaluates to "1" and a false expression evaluates to "0".  Thus we could say:

b= (a <= 5);

and b would be given a value of 0 or 1 depending on whether the expression was true .  [Strictly speaking, if whatever is in the while loop expression is non zero it is true – so while(5) is always true].  Commonly we compare using:

< less than

<= less than or equal to

> greater than

>= greater than or equal to

== equal to

!= not equal to

CAUTION: A common beginner mistake is to use = instead of == in a while loop.  If we write

while (a = 5)
the while statement sets a to 5 and executes the loop until a is false (zero).  This would execute the loop forever.  Everybody makes this mistake at some point in their programming career.

IMPORTANT RULE: in C ! means NOT.  It changes the "truth" value of an expression.  So 

(!(a <= 5)) is the same as (a > 5) and  (!(a == 5)) is the same as (a != 5).  In fact most C programmers simply pronounce the ! as "not" (though some people call it "spling"). 

Exercise 5:

Using a--; (which subtracts 1 from a) rewrite the bean counting program to count beans BACKWARDS from five to one.

[Silly note: for obvious reasons, C has no a** or a// operations to quickly multiply or divide a number by one].

Exercise 6: (your first real C program):

Write a program which calculates the factorial of a number.  Remember that to start a program from scratch select File->New, Win32 Console application and so on as you did with Hello World.

The program should:

i) declare three integers: the number we are calculating the factorial of, a number to hold the answer and a counter for the while loop.

ii) Use a while loop to multiply the answer the correct number of times

iii) Multiply the answer by the appropriate amount each time round the while loop.

iv) Print an answer in the format "The factorial of 4 is 24."

The for loop
One specific type of while loop is so common that it has its own structure.  This is the for loop.  A for loop is a loop with a counter variable which changes every time we go round the loop – just like the one you should have written in exercise 7.  A for loop looks like this:

for (initialise loop counter; test expression; adjust loop counter)

For example, our bean counting program could have been written as:

int i;

for (i= 1; i <= 5; i++) {

    printf ("%d bean(s)\n",i);

}

IMPORTANT RULE: If, like in the above example, the program block for a statement has only one line you can omit the curly brackets. The above bit of code would just be the same written as:

int i;

for (i= 1; i <= 5; i++) 

    printf ("%d bean(s)\n",i);

We suggest that, while you are learning, you keep the brackets in to avoid confusion.

CAUTION: The compiler doesn't actually care what you put in each of the bits of a for loop (if you put anything at all – it's perfectly legal to leave any of the three parts blank) therefore it won't tell you if you've got them in the wrong order.  You could have written:

for (i++; i= 1; i <= 5)

which would not be good – aside from anything else, the for loop sets i to be one and then checks if one is the same as zero – which isn't going to happen any time soon.  In C,  for(;;) and while(1) both mean "loop forever".  As we shall see later this can sometimes be what you want – but usually it isn't.  Remember, in a for loop, the order is initialise the counter, then test the counter, then increment the counter.

Of course a for loop doesn't have to count up in ones:

int i;

for (i= 5; i > 0; i--)

or 

float f;

for (f= 3.7; f > 0.1; f-= 0.3)

work just as well.

CAUTION: There can be problems when comparing floating point numbers – especially if you check for their equality.  For example, numbers like 1/3 cannot be properly represented in floating point numbers since their decimal expansion is infinite.  Therefore, 1/3 + 1/3 + 1/3 is not necessarily equal to one in computer programming – it depends how your computer rounds things off.

Exercise 7:

Rewrite your factorial program from exercise 6 to use a for loop to calculate factorials instead of using a while loop.

Exercise 8:

For loops can be nested one inside the other like so:

int i;

int j;

for (i= 1; i <= 12; i++) {

    for (j= 1; j <= 12; j++) {

         /* code in here will be executed for every value of 

         i from 1-12 and every value of j from 1-12 */

    }

}

Use two for loops, one inside the other, to print out the multiplication tables from 1 to 12 in sequence in the format:

1 x 1 = 1

1 x 2 = 2

all the way up to 12 x 12 = 144

Hint: (obviously, since you have two for loops, make sure you have two variables for loop counters).

Hint2: you will probably want to pipe the output of the program to more (programname | more)  in order to check it properly.

It is traditional for programmers to use i, j and k as loop counters.  There is no compelling reason for this these days [there was a good reason in the days of FORTRAN] but almost every programmer does it.  You could just as well call your loop counter Slartibartfast but it would be much harder to type.

If and else

Another way to test whether expressions are true is using the if statement.  The if statement looks like this:

if (a < b) {

     printf ("a is less than b\n");

}

as usual, we could omit the braces since the code block is only one line long.  However, it is sometimes clearer to leave the braces in – particularly when you are learning.

We can extend the if statement with else thus:

if (a < b) {

    printf ("a is less than b\n");

} else {

    printf ("a is NOT less than b\n");

}

or, if we want to get really carried away:

if (a < b) {

    printf ("a is less than b\n");

} else if (a > b) {

    printf ("a is greater than b\n");

} else {

    printf ("a is equal to b\n");

}

Exercise 9:

Get another copy of beans.c (I promise to stop using this boring example now) and adapt it using if and else so that it is grammatically correct.  E.g. it prints:

1 bean

2 beans 

.

.

etc

More complex conditional expressions

Sometimes we want to evaluate more than one thing in an expression.  For example:

if (a == 1 && b == 2)

or

if (a == 1 ¦¦ b == 2)

The first expression is true if a is 1 AND b is 2.  The second is true if a is 1 OR b is 2 (it is also true if a is one AND b is 2).

IMPORTANT RULE: In C ¦¦ means OR (for strict logicians, it is an INCLUSIVE OR).  && means AND.  

CAUTION: If you are not careful with brackets, ¦¦ and && can be confusing.

if (a == 1 && b == 2 ¦¦ b == 3)

could mean true if a is 1 and b is either 2 or 3 but it could mean true if a is 1 and b is 2 or true if b is 3 (whatever value a has).  As it happens, the compiler thinks && is more important than ¦¦ and therefore the second interpretation is correct the statement is equivalent to :

if ( (a == 1 && b == 2) ¦¦ b == 3)

The precedence rules in C are listed on page 53 of K&R however I would advise you NOT to learn them but instead rely on bracketing everything.  This is clearer, and, if you get into the habit of using brackets you won't be caught out if the rules aren't as you expect and you don't have to remember complex tables.

Debugging programs

Finally, we'll finish this practical with some exercise in debugging.  Every complex program has some bugs in it (and, in these exercises) some simple programs have bugs in. [In fact, it would be miraculous if there wasn't a bug in at least some of the example code we use for this course – please let us know if you find one].  If you continue programming you will spend a lot of your time debugging.  Some simple tips:

1) Find out what compiler messages (if there are any) mean – here's some tips to start with: 

i) Undefined symbol often means you have forgotten to declare a variable or you have misspelled it when you used it.  

ii) Missing opening brackets can trigger peculiar errors – "Unexpected }" might indicate a missing opening bracket.

2) Check each { has a } and each ( has a )
3) Remember that peculiar things can happen when we mix floats and ints

4) Remember that in a printf line, each %d must correspond to an int and each %f to a float.

5) Look at each bit of the code in turn – try to explain to yourself what it should do.

6) Insert printf lines into the program to test values of variables at various points in the program 

7) If the program crashes or does not exit then use printf to find out how far it DOES get.

8) Learn to use a debugging program such as dbx.  (I don't intend to teach you this but it is a useful skill).

9) Get a second mind on the problem.  Ask a friend (preferably one who knows how to program in C) to look at your code and explain it to them.  Often by explaining the program to someone else you can see where it went wrong.

10) If all else fails, take a break, do something else and come back to it later

Exercise 10:

Open the first example: bugger1.cpp and try to persuade it to correctly print out how many days each month has.  Note that there are three separate errors to find.

Exercise 11:

Open the second example: bugger2.cpp and try to persuade it to correctly print out a set of dominoes.  If you get it right there should be 28 of them all different.

Hint: Remember Ctrl-C stops a program which has a loop which doesn't end.

[In case you don’t know, dominoes are English gaming tiles.  They have two ends with different numbers of spots on each end.  A typical set of dominos would have between 0 and 6 spots on each end.]

